FPDF 1.51 Referenz-Handbuch

AcceptPageBreak - automatischen Seitenumbruch akzeptieren oder nicht
AddFont - fügt eine neue Schrift hinzu
AddLink - erzeugt eine dokumentinterne Verknüpfung
AddPage - fügt eine neue Seite hinzu
AliasNbPages - definiert einen Platzhalter für die Gesamtseitenzahl
Cell - erzeugt eine Zelle
Close - schließt das Dokument ab
Error - gibt schwerwiegende Fehler aus
Footer - erstellt das Seitenende
FPDF - Konstruktor
GetStringWidth - ermittelt die Breite einer Zeichenfolge
GetX - gibt die aktuelle horizontale Position zurück
GetY - gibt die aktuelle vertikale Position zurück
Header - erstellt den Seitenanfang
Image - gibt ein Bild aus
Line - zeichnet eine Linie
Link - erzeugt eine Verknüpfung
Ln - Zeilenumbruch
MultiCell - gibt Text mit Zeilenumbrüchen aus
Open - erstellt ein PDF-Dokument
Output - speichern oder ausgeben des Dokumentes
PageNo - gibt die aktuelle Seitenzahl zurück
Rect - zeichnet ein Rechteck
SetAuthor - definiert den Autor
SetAutoPageBreak - legt den Seitenumbruchmodus fest
SetCompression - Kompression ein- oder ausschalten
SetCreator - bestimmt den Ersteller des Dokumentes
SetDisplayMode - legt den Darstellungsmodus fest
SetDrawColor - definiert die Linienfarbe
SetFillColor - definiert die Füllfarbe
SetFont - legt die Schrift fest
SetFontSize - bestimmt die Schriftgröße
SetKeywords - definiert die Schlüsselwörter des Dokumentes
SetLeftMargin - definiert den linken Rand
SetLineWidth - stellt die Linienstärke ein
SetLink - definiert eine Sprungmarke (Verweisziel)
SetMargins - legt die Seitenränder fest
SetRightMargin - legt den rechten Rand fest
SetSubject - definiert den Betreff des Dokumentes
SetTextColor - bestimmt die Textfarbe
SetTitle - definiert den Titel des Dokumentes
SetTopMargin - legt den oberen Rand fest
SetX - setzt die horizontale Position
SetXY - setzt die horizontale und vertikale Position
SetY - setzt die vertikale Position
Text - gibt eine Zeichenfolge aus
Write - gibt Fließtext aus


AcceptPageBreak

boolean AcceptPageBreak()

Version

1.4

Beschreibung

Werden die Bedingungen für den automatischen Seitenumbruch erfüllt, wird diese Methode aufgerufen. Je nach Rückgabewert erfolgt der Umbruch oder nicht. Die Standardeinbettung in FPDF gibt den Wert zurück, der durch SetAutoPageBreak() definiert wurde.
Diese Methode wird automatisch aufgerufen, eine direkte Verwendung innerhalb der Anwendung sollte vermieden werden.

Beispiel

Die Methode wird in einer vererbten Klasse überschrieben, um ein dreispaltiges Layout umzusetzen:

class PDF extends FPDF
{
var $col=0;

function SetCol($col)
{
    //aktuelle Position zu einer Spalte bewegen
    $this->col=$col;
    $x=10+$col*65;
    $this->SetLeftMargin($x);
    $this->SetX($x);
}

function AcceptPageBreak()
{
    if($this->col<2)
    {
        //zur naechsten Spalte wechseln
        $this->SetCol($this->col+1);
        $this->SetY(10);
        return false;
    }
    else
    {
        //zurueck zur erste Spalte und
        //Seitenumbruch ausloesen
        $this->SetCol(0);
        return true;
    }
}
}

$pdf=new PDF();
$pdf->Open();
$pdf->AddPage();
$pdf->SetFont('Arial','',12);
for($i=1;$i<=300;$i++)
    $pdf->Cell(0,5,"Linie $i",0,1);
$pdf->Output();

Siehe auch

SetAutoPageBreak().
Index


AddFont

AddFont(string family [, string style [, string file]])

Version

1.5

Beschreibung

Importiert eine TrueType- oder Type1-Schrift und stellt sie zur Verfügung. Es ist notwendig, mit makefont.php zuvor eine Schriftendefinitions-Datei zu erstellen.
Die Definitionsdatei (und während des Einbettens die Schrift selbst) muss entweder im aktuellen oder dem durch FPDF_FONTPATH bestimmten Verzeichnis vorhanden sein. Werden die Dateien nicht gefunden, wird die Fehlermeldung "Could not include font definition file" erzeugt.

Parameter

family
Die Schriftenfamilie. Der Name kann willkürlich gewählt werden.
style
Der Schriftstil. Mögliche Werte (Groß-/Kleinschreibung wird nicht beachtet):
  • leere Zeichenfolge: normal
  • B: fett
  • I: kursiv
  • BI oder IB: fett, kursiv
Die Standardeinstellung verwendet den Schriftstil 'normal'.
file
Die Schriftendefinitionsdatei.
Bei fehlender Angabe wird der Dateiname aus dem Namen der Schriftenfamilie und dem Schriftstil gebildet (in Kleinbuchstaben und ohne Leerzeichen).

Beispiel

$pdf->AddFont('Comic','I');

ist Equivalent zu:

$pdf->AddFont('Comic','I','comici.php');

Siehe auch

SetFont().


AddLink

int AddLink()

Version

1.5

Beschreibung

Erstellt eine neue interne Verknüpfung und gibt den Kennzeichner der Verknüpfung zurück. Eine interne Verknüpfung ist ein anklickbarer Bereich, welcher auf eine andere Position im selben Dokument verweist.
Der Kennzeichner kann an Cell(), Write(), Image() oder Link() übergeben werden. Die Sprungmarke (das Verweisziel) wird mit SetLink() definiert.

Siehe auch

Cell(), Write(), Image(), Link(), SetLink().


AddPage

AddPage([string orientation])

Version

1.0

Beschreibung

Fügt dem Dokument eine neue Seite hinzu. Wenn bereits eine Seite existiert, wird zuerst Footer() aufgerufen, um das Seitenende auszugeben. Anschließend wird die Seite hinzugefügt und die aktuelle Position, dem linken und oberen Rand entsprechend, auf die linke obere Ecke gesetzt. Zur Ausgabe des Seitenanfangs wird die Methode Header() aufgerufen.
Die zuletzt benutzte Schrift wird automatisch wieder verwendet. Es ist nicht erforderlich erneut SetFont() anzuwenden, wenn mit der selben Schrift fortgefahren werden soll. Dies gilt analog für Farben und Linienstärke.
Der Ursprung des Koordinatensystems liegt in der linken oberen Ecke mit in Richtung Seitenende ansteigenden Werten.

Parameter

orientation
Seitenausrichtung. Mögliche Werte (Groß-/Kleinschreibung wird nicht berücksichtigt):
  • P oder Portrait
  • L oder Landscape
Der Standardwert entspricht der Angabe, die mit dem Klassen-Konstruktor gemacht wurde.

Siehe auch

FPDF(), Header(), Footer(), SetMargins().


AliasNbPages

AliasNbPages([string alias])

Version

1.4

Beschreibung

Definiert einen Platzhalter für die Gesamtseitenzahl, der beim Abschluss des Dokumentes ersetzt wird.

Parameter

alias
Der Platzhalter. Standardwert: {nb}.

Beispiel

class PDF extends FPDF
{
function Footer()
{
    //aktuelle Position 1,5 cm von unten
    $this->SetY(-15);
    //Schrift Arial, kursiv, Größe 8
    $this->SetFont('Arial','I',8);
    //die aktuelle und die Gesamtseitenzahl ausgeben
    $this->Cell(0,10,'Page '.$this->PageNo().'/{nb}',0,0,'C');
}
}

$pdf=new PDF();
$pdf->AliasNbPages();

Siehe auch

PageNo(), Footer().


Cell

Cell(float w [, float h [, string txt [, mixed border [, int ln [, string align [, int fill [, mixed link]]]]]]])

Version

1.0

Beschreibung

Erzeugt eine Zelle (rechteckiger Bereich) mit einer optionalen Umrandung, einer Hintergrundfarbe und einem Ausgabetext. Die linke obere Ecke der Zelle entspricht der aktuellen Position. Der Text kann linksbündig, rechtsbündig oder zentriert ausgerichtet werden. Nach dem Aufruf springt die aktuelle Position nach rechts oder in die nächste Zeile. Es ist möglich, den Text mit einer Verknüpfung zu versehen.
Wenn der automatische Seitenumbruch aktiviert ist und eine Zelle den Seitenrand überschreitet, wird vor der Ausgabe ein Seitenumbruch durchgeführt.

Parameter

w
Zellenweite. Beträgt der Wert 0, dehnt sich die Zelle bis zum rechten Rand aus.
h
Zellenhöhe. Standardwert: 0.
txt
Ausgabetext. Standardwert: leere Zeichenfolge.
border
Gibt an, ob die Zelle mit Randlinien versehen werden soll. Die Werte können wahlweise eine Ziffer:
  • 0: keine Umrandung
  • 1: Rahmen
oder eine Zeichfolge sein, die die folgenden Buchstaben in beliebiger Reihenfolge und Kombination enthält:
  • L: links
  • T: oben
  • R: rechts
  • B: unten
Standardwert: 0.
ln
Legt fest, an welche Stelle die aktuelle Position nach dem Aufruf gesetzt wird. Mögliche Werte:
  • 0: nach rechts
  • 1: an den Anfang der nächsten Zeile
  • 2: darunter
Die Verwendung des Wertes 1 entspricht dem Gebrauch von 0 und dem Aufruf von Ln() unmittelbar nach Cell(). Standardwert: 0.
align
Ermöglicht die Ausrichtung des Textes. Mögliche Werte:
  • L oder keine Angabe: linksbündig (Standard)
  • C: zentriert
  • R: rechtsbündig
fill
Definiert, ob der Zellenhintergrund gefüllt wird (1) oder transparent bleibt (0). Standardwert: 0.
link
URL oder von AddLink() zurückgegebener Kennzeichner.

Beispiel

//Schrift bestimmen
$pdf->SetFont('Arial','B',16);
//8 cm breite Zelle erstellen
$pdf->Cell(80);
//rechts daneben, zentrierter Text in einer umrandeten
//20*10 mm Zelle, die aktuelle Position in nächster Zeile
$pdf->Cell(20,10,'Titel',1,1,'C');

Siehe auch

SetFont(), SetDrawColor(), SetFillColor(), SetTextColor(), SetLineWidth(), AddLink(), Ln(), MultiCell(), Write(), SetAutoPageBreak().


Close

Close()

Version

1.0

Beschreibung

Schließt das PDF-Dokument ab. Der Aufruf dieser Methode ist nicht explizit erforderlich, da Output() dies automatisch durchführt.
Wenn das Dokument keine Seite enthält, erfolgt ein Aufruf von AddPage(), um ein ungültiges PDF-Dokument zu vermeiden.

Siehe auch

Open(), Output().


Error

Error(string msg)

Version

1.0

Beschreibung

Bei Auftreten eines schwerwiegenden Fehlers wird diese Methode automatisch aufgerufen; Sie gibt die Fehlermeldung aus und stoppt die weitere Ausführung. Eine vererbte Klasse kann die Fehlerausgabe zur Individualisierung der Fehlerbehandlung unterdrücken, sollte das Skript jedoch immer anhalten, da das resultierende Dokument möglicherweise ungültig sein wird.

Parameter

msg
Die Fehlermeldung.


Footer

Footer()

Version

1.0

Beschreibung

Diese Methode erzeugt das Seitenende, sie wird automatisch von AddPage() und Close() aufgerufen. Eine direkte Verwendung innerhalb der Anwendung sollte vermieden werden. Die Einbettung in FPDF ist leer, für spezielle Abläufe kann die Methode über Unterklassen angepasst werden.

Beispiel

class PDF extends FPDF
{
function Footer()
{
    //aktuelle Position 1,5 cm von unten
    $this->SetY(-15);
    //Schrift Arial, kursiv, Größe 8
    $this->SetFont('Arial','I',8);
    //zentriert die Seitenzahl ausgeben
    $this->Cell(0,10,'Seite '.$this->PageNo(),0,0,'C');
}
}

Siehe auch

Header().


FPDF

FPDF([string orientation [, string unit [, mixed format]]])

Version

1.0

Beschreibung

Erzeugt die Klasse und ermöglicht das Festlegen der Seitenausrichtung sowie der Maßeinheiten, die in allen Methoden Verwendung finden (ausgenommen der Schriftengrößen).

Parameter

orientation
Seitenausrichtung. Mögliche Werte (Groß-/Kleinschreibung wird nicht berücksichtigt):
  • P oder Portrait
  • L oder Landscape
Standardwert: P.
unit
Benutzerdefinierte Maßeinheit. Mögliche Werte:
  • pt: Punkt
  • mm: Millimeter
  • cm: Zentimeter
  • in: Zoll
Ein Punkt entspricht 1/72 Zoll, das sind ca. 0,35 mm (ein Zoll sind 2,54 cm). In der Typographie ist dies eine übliche Maßeinheit; Schriftgrößen werden in Punkt angegeben.

Der Standardwert ist mm.
format
Das Seitenformat. Mögliche Werte (Groß-/Kleinschreibung wird nicht berücksichtigt):
  • A3
  • A4
  • A5
  • Letter
  • Legal
Alternativ kann auch ein Array mit zwei Elementen, zur benutzerdefinierten Bestimmung der Breite und Höhe, übergeben werden. Die Werte des Arrays müssen der in unit bestimmten Maßeinheit entsprechen.


GetStringWidth

float GetStringWidth(string s)

Version

1.2

Beschreibung

Gibt die Breite einer Zeichenkette in der festgelegten Maßeinheit zurück. Eine Schrift muss ausgewählt sein.

Parameter

s
Die Zeichenkette, deren Breite ermittelt werden soll.


GetX

float GetX()

Version

1.2

Beschreibung

Gibt die X-Koordinate (horizontal) der aktuellen Position zurück.

Siehe auch

SetX(), GetY(), SetY().


GetY

float GetY()

Version

1.0

Beschreibung

Gibt die Y-Koordinate (vertikal) der aktuellen Position zurück.

Siehe auch

SetY(), GetX(), SetX().


Header

Header()

Version

1.0

Beschreibung

Diese Methode erzeugt den Seitenanfang, sie wird automatisch von AddPage() und Close() aufgerufen. Eine direkte Verwendung innerhalb der Anwendung sollte vermieden werden. Die Einbettung in FPDF ist leer, für spezielle Abläufe kann die Methode über Unterklassen angepasst werden.

Beispiel

class PDF extends FPDF
{
function Header()
{
    //Schrift Arial, fett, Größe 15
    $this->SetFont('Arial','B',15);
    //Zelle von 8 cm Breite erstellen
    $this->Cell(80);
    //rechts daneben eine weitere Zelle erzeugen
    //Attribute: 3 cm breit, 1 cm hoch, Text 'Titel',umrandet,
    //aktuelle Position rechts, Textausrichtung zentriert
    $this->Cell(30,10,'Titel',1,0,'C');
    //Zeilenumbruch
    $this->Ln(20);
}
}

Siehe auch

Footer().


Image

Image(string file, float x, float y, float w [, float h [, string type [, mixed link]]])

Version

1.1

Beschreibung

Gibt ein Bild in der Seite aus. Die linke obere Ecke und mindestens eine der beiden Größenangaben müssen definiert werden; die zweite Größenangabe kann ebenfalls definiert oder unter Beibehaltung der Bildproportionen automatisch berechnet werden.

Unterstützt werden JPEG- und PNG-Dateien.

Folgende JPEG-Typen werden unterstützt:
  • Graustufen
  • RGB (24 Bit)
  • CMYK (32 Bit)
Folgende PNG-Typen werden unterstützt:
  • Graustufen mit höchstens 8 Bit Farbtiefe (256 Abstufungen)
  • indizierte Farben
  • RGB (24 Bit)
nicht unterstützte Eigenschaften:
  • Interlacing
  • Alpha-Kanal
Wenn eine transparente Farbe definiert wurde, so wird diese übernommen, kann allerdings erst von Acrobat 4 oder höher dargestellt werden.

Das Format (JPEG oder PNG) kann wahlweise explizit angegeben oder anhand der Dateiendung ermittelt werden.

Das Bild kann mit einer Verknüpfung versehen werden.

Findet ein Bild mehrfach Verwendung, wird nur eine einzige Kopie in das PDF-Dokument eingebettet.

Parameter

file
Name der Bilddatei.
x
Horizontale Position der linken oberen Ecke.
y
Vertikale Position der linken oberen Ecke.
w
Breite, in der das Bild im Dokument dargestellt werden soll. Wird 0 angegeben, erfolgt eine automatische Berechnung der Breite unter Beibehaltung der Bildproportionen.
h
Höhe, in der das Bild im Dokument dargestellt werden soll. Wird kein Wert oder 0 angegeben, erfolgt eine automatische Berechnung der Höhe unter Beibehaltung der Bildproportionen.
type
Das Bildformat. Mögliche Werte (Groß-/Kleinschreibung wird nicht beachtet): JPG, JPEG, PNG. Wenn nicht angegeben, wird versucht, den Typ anhand der Dateiendung zu ermitteln.
link
URL oder von AddLink() zurückgegebener Kennzeichner.

Siehe auch

AddLink().


Line

Line(float x1, float y1, float x2, float y2)

Version

1.0

Beschreibung

Zeichnet eine Linie zwischen zwei angegebenen Punkten.

Parameter

x1
Horizontale Position des ersten Punktes.
y1
Vertikale Position des ersten Punktes.
x2
Horizontale Position des zweiten Punktes.
y2
Vertikale Position des zweiten Punktes.

Siehe auch

SetLineWidth(), SetDrawColor().


Link

Link(float x, float y, float w, float h, mixed link)

Version

1.5

Beschreibung

Erzeugt eine Verknüpfung in einem rechteckigen Bereich auf der Seite. Verknüpfungen mit Text oder Bildern werden gewöhnlich mit Cell(), Write() oder Image() erstellt, diese Methode kann jedoch nützlich sein, um zum Beispiel einen anklickbaren Bereich innerhalb eines Bildes zu erstellen.

Parameter

x
Die horizontale Position der linken oberen Ecke des Verknüpfungsbereiches.
y
Die vertikale Position der linken oberen Ecke des Verknüpfungsbereiches.
w
Die Breite des Bereiches.
h
Die Höhe des Bereiches.
link
URL oder von AddLink() zurückgegebener Kennzeichner.

Siehe auch

AddLink(), Cell(), Write(), Image().


Ln

Ln([float h])

Version

1.0

Beschreibung

Erzeugt einen Zeilenumbruch. Die aktuelle horizontale Position springt zurück an den linken Seitenrand, die aktuelle vertikale Position verschiebt sich um den im Parameter angegebenen Wert.

Parameter

h
Die Höhe des Zeilenvorschubs. Wird kein Wert angegeben, verschiebt sich die Position um die Höhe, die der zuletzt ausgegebenen Zelle zugewiesen wurde.

Siehe auch

Cell().


MultiCell

MultiCell(float w, float h, string txt [, mixed border [, string align [, int fill]]])

Version

1.3

Beschreibung

Diese Methode erlaubt die Ausgabe von Text mit Zeilenumbrüchen. Diese können automatisch (sobald der Text den rechten Rand der Zelle erreicht) oder explizit (über das Steuerzeichen \n) erzeugt werden. Es werden untereinander so viele Zellen wie erforderlich erstellt.
Der Text kann links- und rechtsbündig, zentriert oder als Blocksatz ausgerichtet werden. Der Zellenblock kann mit einer Randlinie und der Hintergrund mit einer Einfärbung versehen werden.

Parameter

w
Die Breite der Zellen. Falls 0, erstrecken sich die Zellen bis an den rechten Seitenrand.
h
Die Höhe der Zellen.
txt
Der Ausgabetext.
border
Gibt an, ob der Zellenblock mit Randlinien versehen werden soll. Die Werte können wahlweise eine Ziffer:
  • 0: keine Umrandung
  • 1: Rahmen
oder eine Zeichfolge sein, die die folgenden Buchstaben in beliebiger Reihenfolge und Kombination enthält:
  • L: links
  • T: oben
  • R: rechts
  • B: unten
Standardwert: 0.
align
Legt die Textausrichtung fest. Mögliche Werte:
  • L: linksbündig
  • C: zentriert
  • R: rechtsbündig
  • J: Blocksatz (Standardwert)
fill
Definiert einen gefüllten (1) oder transparenten (0) Hintergrund. Standardwert: 0.

Siehe auch

SetFont(), SetDrawColor(), SetFillColor(), SetTextColor(), SetLineWidth(), Cell(), Write(), SetAutoPageBreak().


Open

Open()

Version

1.0

Beschreibung

Diese Methode startet die PDF-Generierung; sie muss vor der Verwendung der Ausgabe-Methoden aufgerufen werden. Durch diese Methode wird keine Seite erstellt, daher ist es erforderlich, von AddPage() Gebrauch zu machen.

Siehe auch

AddPage(), Close().


Output

Output([string file [, boolean download]])

Version

1.0

Beschreibung

Speichert das PDF-Dokument in einer lokalen Datei oder sendet es zum Browser. Im letzteren Fall, wird gegebenenfalls ein PDF-Plug-in (sofern vorhanden) zur Darstellung verwendet oder ein Download ("Speichern unter..."-Dialog) eingeleitet.
Falls erforderlich ruft die Methode Close() auf, um das Dokument abzuschließen.

Parameter

file
Der Dateiname für das PDF-Dokument. Falls leer oder nicht angegeben, wird das Dokument zum Browser gesendet und vom Plug-in dargestellt (falls vorhanden).
download
Wenn file angegeben wurde bestimmt dieser Parameter, ob die Datei lokal gespeichert (false) oder and den Browser gesendet und ein "Speichern unter ..."-Dialog geöffnet wird (true).
Standardwert: false.

Siehe auch

Close().


PageNo

int PageNo()

Version

1.0

Beschreibung

Gibt die aktuelle Seitenzahl zurück.

Siehe auch

AliasNbPages().


Rect

Rect(float x, float y, float w, float h [, string style])

Version

1.0

Beschreibung

Gibt ein Rechteck aus. Füllung und Umrandung können einzeln oder kombiniert zugewiesen werden.

Parameter

x
Horizontale Position der linken oberen Ecke.
y
Vertikale Position der linken oberen Ecke.
w
Breite.
h
Höhe.
style
Stil des Rechtecks. Mögliche Werte:
  • D oder keine Angabe: nur Umrandung. Standardwert.
  • F: Füllung.
  • DF oder FD: Umrandung und Füllung.

Siehe auch

SetLineWidth(), SetDrawColor(), SetFillColor().


SetAuthor

SetAuthor(string author)

Version

1.2

Beschreibung

Legt den Autor des Dokumentes fest.

Parameter

author
Der Name des Autors.

Siehe auch

SetCreator(), SetKeywords(), SetSubject(), SetTitle().


SetAutoPageBreak

SetAutoPageBreak(boolean auto [, float margin])

Version

1.0

Beschreibung

Aktiviert oder Deaktiviert den automatischen Seitenumbruch. Ist dieser Modus aktiviert, wird durch den zweiten Parameter die Entfernung vom Seitenende bestimmt, die die Auslöseschwelle definiert. Per Standard ist dieser Modus aktiviert und die Auslöseschwelle (margin) auf 2 cm gesetzt.

Parameter

auto
Aktivieren (true) oder deaktivieren (false) des automatischen Seitenumbruchs.
margin
Auslöseschwelle; Abstand vom Seitenende.

Siehe auch

Cell(), MultiCell(), AcceptPageBreak().


SetCompression

SetCompression(boolean compress)

Version

1.4

Beschreibung

Aktiviert oder deaktiviert die Kompression des Dokumentes. Sofern aktiviert, wird der Quelltext jeder Seite komprimiert und somit die Größe der resultierenden Datei um durchschnittlich den Faktor 2 reduziert.
In der Standardeinstellung ist die Kompression aktiviert.

Achtung: für diese Funktion ist die Zlib-Erweiterung erforderlich. Fehlt diese, wird die Kompression abgeschaltet.

Parameter

compress
Aktivieren (true) oder deaktivieren (false) der Kompression.


SetCreator

SetCreator(string creator)

Version

1.2

Beschreibung

Definiert den Ersteller des Dokumentes. Üblich ist hier der Name der Anwendung, die das PDF erzeugt.

Parameter

creator
Der Name des Erstellers.

Siehe auch

SetAuthor(), SetKeywords(), SetSubject(), SetTitle().


SetDisplayMode

SetDisplayMode(mixed zoom [, string layout])

Version

1.2

Beschreibung

Definiert die Art, in der das Dokument angezeigt wird. Seiten können vollständig, in der vollen Breite des Programmfensters, in der Originalgröße, mit einem bestimmten Zoom-Faktor oder mit den Benutzereinstellungen (den Voreinstellungen von Acrobat) angezeigt werden. Außerdem kann das Seitenlayout bestimmt werden: einzelne Seiten, fortlaufende Seiten, fortlaufende Doppelseiten oder Benutzereinstellungen.
Standardwert: Dokumente nutzen die volle Fensterbreite mit fortlaufender Seitendarstellung.

Parameter

zoom
Der Darstellungsmodus. Mögliche Werte:
  • fullpage: Stellt eine gesamte Seite auf dem Bildschirm dar.
  • fullwidth: Dokument nutzt die gesamte Breite des Fensters.
  • real: Originalgröße (entspricht 100 % Zoom).
  • default: verwendet die Benutzereinstellungen.
oder eine Zahl mit dem zu verwendendem Zoom-Faktor.
layout
Das Seitenlayout. Mögliche Werte:
  • single: zeigt jeweils nur eine Seite
  • continuous: zeigt die Seiten fortlaufend
  • two: zeigt fortlaufende Doppelseiten
  • default: verwendet die Benutzereinstellungen
Standardwert: continuous.


SetDrawColor

SetDrawColor(int r [, int g, int b])

Version

1.3

Beschreibung

Definiert die zu verwendende Farbe für alle Umrandungen (Linien, Rechtecke und Zellen). Die Angabe erfolgt wahlweise in RGB-Werten oder Graustufen. Die Methode kann vor dem Erzeugen der ersten Seite aufgerufen werden, die Werte bleiben von Seite zu Seite erhalten.

Parameter

r
Wenn die Parameter g und b angegeben sind, stellt r den Rot-Anteil; andernfalls bestimmt r die Graustufen. Wertebereich 0 bis 255.
g
Grün-Anteil. Wertebereich 0 bis 255.
b
Blau-Anteil. Wertebereich 0 bis 255.

Siehe auch

SetFillColor(), SetTextColor(), Line(), Rect(), Cell(), MultiCell().


SetFillColor

SetFillColor(int r [, int g, int b])

Version

1.3

Beschreibung

Definiert die zu verwendende Farbe für alle Füllungen (gefüllte Rechtecke und Zellhintergründe). Die Angabe erfolgt wahlweise in RGB-Werten oder Graustufen. Die Methode kann vor dem Erzeugen der ersten Seite aufgerufen werden, die Werte bleiben von Seite zu Seite erhalten.

Parameter

r
Wenn die Parameter g und b angegeben sind, stellt r den Rot-Anteil; andernfalls bestimmt r die Graustufen. Wertebereich 0 bis 255.
g
Grün-Anteil. Wertebereich 0 bis 255.
b
Blau-Anteil. Wertebereich 0 bis 255.

Siehe auch

SetDrawColor(), SetTextColor(), Rect(), Cell(), MultiCell().


SetFont

SetFont(string family [, string style [, float size]])

Version

1.0

Beschreibung

Bestimmt die Schriftart, die bei der Ausgabe von Zeichen vorgegeben wird. Es ist erforderlich diese Methode mindestens einmal vor der Ausgabe von Text aufzurufen, da das resultierende Dokument sonst ungültig wird.
Es können Standardschriften oder über AddFont() hinzugefügte Schriften verwendet werden. Standardschriften verwendeten den Zeichensatz Windows-1252 (westeuropäisch).
Die Methode kann vor der ersten Seite angewendet werden, die definierte Schrift bleibt dann von Seite zu Seite erhalten.
Wenn lediglich die Schriftgröße verändert werden soll, empfiehlt sich der Gebrauch von SetFontSize().

Achtung: Für die Standardschriften müssen die Schriften-Metrik-Dateien zugänglich sein. Hierzu bestehen drei Möglichkeiten:
  • Die Metrik-Dateien sind im selben Verzeichnis wie das Skript bzw. in dem Verzeichnis, in dem sich das Skript zur Laufzeit befindet.
  • Sie liegen in einem der durch den include_path Parameter definierten Verzeichnisse.
  • Sie befinden sich in dem Verzeichnis, das über die FPDF_FONTPATH-Konstante angegeben ist.
Beispiel für den zuletzt genannten Fall (bitte den abschließenden Schrägstrich beachten):

define('FPDF_FONTPATH','/home/www/font/');
require('fpdf.php');

Wird die zu der angegebenen Schrift genannte Metrik-Datei nicht gefunden, wird die Fehlermeldung "Could not include font metric file" generiert.

Parameter

family
Die gewünschte Schriftenfamilie. Wahlweise ein über AddFont() definierter Name oder eine der Standardschriften (Groß-/Kleinschreibung wird nicht beachtet):
  • Courier (Festbreitenschrift)
  • Helvetica oder Arial (serifenlose Schrift)
  • Times (Serifenschrift)
  • Symbol (Symbole)
  • ZapfDingbats (Symbole)
Es it ebenso möglich, eine leere Zeichenfolge anzugeben. In diesem Fall wird die zuvor verwendete Schrift beibehalten.
style
Der Schriftstil. Mögliche Werte (Groß-/Kleinschreibung wird nicht beachtet):
  • leere Zeichenfolge: normal (Standardwert)
  • B: fett
  • I: kursiv
  • U: unterstrichen
oder beliebige Kombinationen davon. Schriftstile haben keinen Einfluss auf die Symbolschriften (Symbol und ZapfDingbats)
size
Schriftgröße in Punkte.
Der Standardwert ist die zuvor verwendete Größe. Wenn die Größe seit dem Start des Dokumentes noch nicht definiert wurde, wird der Wert 12 verwendet.

Beispiel

//Times normal, 12 Pt.
$pdf->SetFont('Times');
//Arial fett, 14 Pt.
$pdf->SetFont('Arial','B',14);
//Schriftstil fett entfernen
$pdf->SetFont('');
//Times fett, kursiv, unterstrichen, 14 Pt.
$pdf->SetFont('Times','BIU');

Siehe auch

AddFont(), SetFontSize(), Cell(), MultiCell(), Write().


SetFontSize

SetFontSize(float size)

Version

1.0

Beschreibung

Legt die Größe der aktuell verwendeten Schrift fest.

Parameter

size
Die Größe (in Punkte).

Siehe auch

SetFont().


SetKeywords

SetKeywords(string keywords)

Version

1.2

Beschreibung

Definiert die Schlüsselworte des Dokumentes. Das übliche Format ist 'keyword1 keyword2 ...'.

Parameter

keywords
Die Schlüsselworte.

Siehe auch

SetAuthor(), SetCreator(), SetSubject(), SetTitle().


SetLeftMargin

SetLeftMargin(float margin)

Version

1.4

Beschreibung

Legt den linken Randabstand fest. Diese Methode kann vor dem Erstellen der ersten Seite aufgerufen werden.
Wenn die horizontale Position die Seitenbreite übersteigt, wird die Einstellung auf den Randbereich zurückgesetzt.

Parameter

margin
Der Rand (entsprechend der festgelegten Maßeinheit).

Siehe auch

SetTopMargin(), SetRightMargin(), SetAutoPageBreak(), SetMargins().


SetLineWidth

SetLineWidth(float width)

Version

1.0

Beschreibung

Definiert die Linienstärke. Wird die Methode nicht benutzt, findet der Standardwert von 0,2 mm Verwendung. Die Methode kann vor dem Erstellen der ersten Seite aufgerufen werden, und der Wert bleibt von Seite zu Seite erhalten.

Parameter

width
Die Linienstärke.

Siehe auch

Line(), Rect(), Cell(), MultiCell().


SetLink

SetLink(int link [, float y [, int page]])

Version

1.5

Beschreibung

Definiert die Seite und die Position, auf die eine Verknüpfung verweist.

Parameter

link
Der von AddLink() zurückgegebene Kennzeichner der Verknüpfung.
y
Die vertikale Position der Sprungmarke; -1 definiert die aktuelle Position. Der Standardwert ist 0 (Seitenanfang).
page
Die Seitenzahl; -1 definiert die aktuelle Seite (Standardwert).

Siehe auch

AddLink().


SetMargins

SetMargins(float left, float top [, float right])

Version

1.0

Beschreibung

Definiert den linken, oberen und rechten Randbereich. Wird die Methode nicht benutzt, findet der Standardwert von 1 cm Verwendung.

Parameter

left
Linker Rand.
top
Oberer Rand.
right
Rechter Rand. Der Standardwert entspricht der Breite des linken Randes.

Siehe auch

SetLeftMargin(), SetTopMargin(), SetRightMargin(), SetAutoPageBreak().


SetRightMargin

SetRightMargin(float margin)

Version

1.5

Beschreibung

Definiert den rechten Seitenrand. Diese Methode kann vor dem Erstellen der ersten Seite aufgerufen werden.

Parameter

margin
Der Rand (entsprechend der festgelegten Maßeinheit).

Siehe auch

SetLeftMargin(), SetTopMargin(), SetAutoPageBreak(), SetMargins().


SetSubject

SetSubject(string subject)

Version

1.2

Beschreibung

Definiert den Betreff des Dokumentes.

Parameter

subject
Der Betreff.

Siehe auch

SetAuthor(), SetCreator(), SetKeywords(), SetTitle().


SetTextColor

SetTextColor(int r [, int g, int b])

Version

1.3

Beschreibung

Definiert die Farbe für die Schrift. Die Angabe erfolgt wahlweise in RGB-Werten oder Graustufen. Die Methode kann vor dem Erzeugen der ersten Seite aufgerufen werden, die Werte bleiben von Seite zu Seite erhalten.

Parameter

r
Wenn die Parameter g und b angegeben sind, stellt r den Rot-Anteil; andernfalls bestimmt r die Graustufen. Wertebereich 0 bis 255.
g
Grün-Anteil. Wertebereich 0 bis 255.
b
Blau-Anteil. Wertebereich 0 bis 255.

Siehe auch

SetDrawColor(), SetFillColor(), Text(), Cell(), MultiCell().


SetTitle

SetTitle(string title)

Version

1.2

Beschreibung

Definiert den Titel für das Dokument.

Parameter

title
Der Titel.

Siehe auch

SetAuthor(), SetCreator(), SetKeywords(), SetSubject().


SetTopMargin

SetTopMargin(float margin)

Version

1.5

Beschreibung

Definiert den oberen Seitenrand. Diese Methode kann vor dem Erstellen der ersten Seite aufgerufen werden.

Parameter

margin
Der Rand (entsprechend der festgelegten Maßeinheit).

Siehe auch

SetLeftMargin(), SetRightMargin(), SetAutoPageBreak(), SetMargins().


SetX

SetX(float x)

Version

1.2

Beschreibung

Definiert den horizontalen Wert für die aktuelle Position. Ist der angegebene Wert negativ, wird dieser von der rechten Seitenbegrenzung abgezogen.

Parameter

x
Der horizontale Wert.

Siehe auch

GetX(), GetY(), SetY(), SetXY().


SetXY

SetXY(float x, float y)

Version

1.2

Beschreibung

Definiert die horizontalen und vertikalen Werte für die aktuelle Position. Sind die angegebenen Werte negativ, werden sie von der rechten bzw. unteren Seitenbegrenzung abgezogen.

Parameter

x
Der horizontale Wert.
y
Der vertikale Wert.

Siehe auch

SetX(), SetY().


SetY

SetY(float y)

Version

1.0

Beschreibung

Bewegt die aktuelle Position an die linke Seite und zu dem angegebenen vertikalen Wert. Ist der angegebene Wert negativ, wird dieser von der unteren Seitenbegrenzung abgezogen.

Parameter

y
Der vertikale Wert.

Siehe auch

GetX(), GetY(), SetY(), SetXY().


Text

Text(float x, float y, string txt)

Version

1.0

Beschreibung

Gibt eine Zeichenfolge aus. Der Ausgangspunkt ist an der linken Seite des ersten Buchstabens, in Höhe der Grundlinie. Diese Methode erlaubt es, Text präzise auf der Seite zu platzieren.

Parameter

x
Der horizontale Wert für den Ausgangspunkt.
y
Der vertikale Wert für den Ausgangspunkt.
txt
Der Ausgabetext.

Siehe auch

SetFont(), SetTextColor(), Cell(), MultiCell(), Write().


Write

Write(float h, string txt [, mixed link])

Version

1.5

Beschreibung

Diese Methode gibt Text an der aktuellen Schreibposition aus. Der Text wird am rechten Rand (oder bei Auftreten des Steuerzeichens \n) umgebrochen und am linken Seitenrand fortgesetzt. Nach dem Beenden der Textausgabe bleibt die Schreibposition am Ende des Textes.
Es ist möglich, den Text mit einer Verknüpfung zu versehen.

Parameter

h
Die Zeilenhöhe.
txt
Der Ausgabetext.
link
URL oder von AddLink() zurückgegebener Kennzeichner.

Beispiel

//Mit Standardschrift beginnen
$pdf->SetFont('Arial','',14);
$pdf->Write(5,'Visit ');
//Anschließend eine blaue,
//unterstrichene Verknüpfung ausgeben
$pdf->SetTextColor(0,0,255);
$pdf->SetFont('','U');
$pdf->Write(5,'www.fpdf.org','http://www.fpdf.org');

Siehe auch

SetFont(), SetTextColor(), AddLink(), MultiCell(), SetAutoPageBreak().